User Tools

Site Tools


Google Earth Mass Export

Export to Google Earth

Description

With this command the objects from the Objekt-Manager are transferred to Google Earth. This way, you can display your drawing objects directly in Google Earth. (eg. in the Facility Management for displaying maintenance areas)

Procedure

  1. Open Google Earth.
  2. Switch to the drawing in the DATAflor CAD Program and select in the Object-Manager in the Menu Google Earth > to Google Earth.
  3. The selected object tree is imported into Google Earth and displayed.
  4. To zoom in on the objects in Google Earth you have to double-click in the field Places on the top entry of the exported object tree structure.

To display the object tree in Google Earth Google Earth graphics are necessary. Please find more information in Transfer graphic.

Method

After opening the function for the export the selected object tree structure is transferred to Google Earth. There, an object tree containing all objects with allocated Google Earth graphics is created in the field Places. Additionally, the information is saved as KML-file.

The files are saved to the user directory of DATAflor CAD in the folder Google Earth\Massen.

For the export of the object tree can also settings be made regarding the description, for instance. Please refer to Options > Tab Google Earth.

When using subtraction objects: Google Earth does not know subtraction areas, hence, these objects are displayed in the colour of the base object. You can amend the display later on. To do this, select the folder in the field Places which the subtraction objects were allocated to originally. Select with right-click on the object the Properties. In the tab Style/Color you can specify the style and colour of the objects. Switch to the tab Altitude and enter the value 1 in the field Altitude. Then select the arrow next to the entry relative to ground or select from the list clamped to ground (the height is re-set to 0m). Close the window Properties with the button [OK].


Export as kml-file

Description

This function saves the object tree as KML-file. This can be necessary if Google Earth is not installed on the computer.

Method

After opening the function of the export as KML-file the dialogue for the file selection appears. The name for the new file is pre-defined, but can be entered manually as well. The created KML-file can then be imported into Google Earth via the menu File > Open. When opening the file, Google Earth zooms automatically in on the objects.

To display the object tree in Google Earth Google Earth graphics are necessary. Please find more information in Transfer graphic.


Send

Description

When using Outlook a KML-file is attached to a new Mail Message. Thereby, the object tree is saved automatically as KML-file.

Method

The created KML-file can then be imported into Google Earth via the menu File > Open. When opening the file, Google Earth zooms automatically in on the objects.

To display the object tree in Google Earth Google Earth graphics are necessary. Please find more information in Transfer graphic.

To use this function Outlook has to be opened.


OnlineServer

By using a server the data can be provided and managed on the internet (password-protected).

The implementation of this function is planned for one of the next versions.


Transfer graphic

Description

In Google Earth the graphic properties of the objects are managed in a different way than in DATAlor CAD. Therefore, to display the object tree in Google Earth Google Earth graphics are necessary. With this function you can transfer the graphics of existing graphic options automatically to Google Earth graphics.

Since this is solely a graphic for use in Google Earth, is remains invisible in DATAflor CAD. Google Earth cannot display a hatch pattern, therefore all graphics are displayed with solid hatches.

You can also create your own Google Earth graphics. Please find more information in Google Earth graphic

Method

For the activated branch the existing graphics are saved as Google Earth graphics.
If there is no graphic allocated to a graphic option a Google Earth graphic will not be created.

Also, there is no Google Earth graphic created for deactivated graphic options.

If there are multiple graphics of the same object type allocated to a graphic option only the first graphic of the graphic option is transferred into a Google Earth graphic.

If there are multiple graphics of different object types allocated to a graphic option the first graphic of each object type is transferred.

Google Earth graphics in deactivated graphic options are not exported to Google Earth.

If there are multiple graphic options with Google Earth graphics activated, then the object is created multiple times in Google Earth, because for each allocated Google Earth graphic an object is created in Google Earth.


Import from BUSINESS

Import of an KML-file created in DATAflor BUSINESS to display updated working stages.

The implementation of this function is planned for one of the next versions.

back to page top | Mail to DATAflor | Copyright page | Data protection